Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 3 months ago. Jul 07, 2017 - 11:13 EDT
Update
At this time, customers may experience delays with new list creation. Our team is working to identify the issue and will provide updates as they become available. We apologize for any inconvenience.
Posted 3 months ago. Jul 07, 2017 - 10:43 EDT
Identified
We are currently experiencing an unscheduled service interruption. At this time, there is degraded experience when creating a new account. We appreciate your patience.
Posted 3 months ago. Jul 07, 2017 - 10:37 EDT