Unscheduled Interruption
Incident Report for AWeber
Resolved
Customer logins are once again operational. Thank you for your patience as our team worked to resolve the interruption.
Posted 25 days ago. Dec 30, 2017 - 00:27 EST
Investigating
We're currently experiencing an unscheduled interruption that is impacting customer logins. It appears all other services, including email sending and subscriber sign ups, are functioning normally. Our team is working on addressing the interruption as we speak. Thank you for your patience.
Posted 25 days ago. Dec 29, 2017 - 23:58 EST