[Scheduled] Scheduled Maintenance
Incident Report for AWeber
Resolved
Our scheduled maintenance is complete. We appreciate your patience.
Posted about 1 year ago. Oct 14, 2016 - 15:56 EDT
Identified
In an effort to continually improve our services, we will be performing system maintenance between 2pm to 4pm ET. At this time, European customers may not able to host sign up forms or collect subscriber signups. Mobile applications will still be available at this time, as well as manual imports. We appreciate your patience.
Posted about 1 year ago. Oct 14, 2016 - 12:01 EDT