Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience!
Posted 6 months ago. Jul 03, 2017 - 15:18 EDT
Identified
We're currently experiencing an unscheduled service interruption. At this time, customers may experience delays in list automation and sending broadcast messages. Our team is working to identify the issue and will provide updates as they become available. We apologize for any inconvenience.
Posted 6 months ago. Jul 03, 2017 - 15:15 EDT