Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. Customers should now see new subscribers in their AWeber account. We appreciate your patience.
Posted 4 months ago. Jun 12, 2017 - 13:53 EDT
Investigating
We are currently experiencing an unscheduled service interruption. At this time, customers may see a delay in new subscribers appearing in their AWeber account. Our team has identified the cause and is now investigating. We appreciate your patience as we work to resolve the issue.
Posted 4 months ago. Jun 12, 2017 - 13:26 EDT