Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 11 months ago. Oct 21, 2016 - 10:00 EDT
Identified
We are currently experiencing an unscheduled service interruption. Customers may experience interruptions with credit card processing. Some customers may also experience interruptions or delays when accessing the aweber.com site. Our team has identified the cause and is working to resolve. We appreciate your patience.
Posted 11 months ago. Oct 21, 2016 - 08:45 EDT