Scheduled Maintenance
Incident Report for AWeber
Resolved
Our scheduled maintenance is complete. We appreciate your patience.
Posted about 1 month ago. Jul 06, 2017 - 20:31 EDT
Identified
AWeber will be performing system maintenance at 8:15pm. At this time, customers may experience delays in email sending, message analytics, and confirmed opt-in messages. We appreciate your patience.
Posted about 1 month ago. Jul 06, 2017 - 19:41 EDT