Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 10 months ago. Jul 20, 2016 - 14:24 EDT
Identified
We are currently experiencing a delay in broadcast analytics. Our team has identified the cause and is working to resolve the issue. No data has been lost. We appreciate your patience.
Posted 10 months ago. Jul 20, 2016 - 09:52 EDT