Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 4 months ago. Jan 16, 2017 - 09:05 EST
Investigating
We're currently experiencing an unscheduled service interruption. At this time, customers may not be able to view, update, create or delete draft messages. Our team is working to identify the issue and will provide updates as they become available. We apologize for any inconvenience.
Posted 4 months ago. Jan 16, 2017 - 08:39 EST