Unscheduled Interruption
Incident Report for AWeber
Resolved
All issues related to the unscheduled interruption with Campaigns have been resolved. We appreciate your patience.
Posted 4 months ago. Jun 26, 2017 - 15:03 EDT
Investigating
We are currently experiencing an unscheduled service interruption. At this time, customers are not able to create, edit or save Campaigns. We will provide updates as they become available. We appreciate your patience as we work to resolve the issue.
Posted 4 months ago. Jun 26, 2017 - 14:50 EDT