Password Resets Unavailable
Incident Report for AWeber
Resolved
Our password reset function is once again available. Thank you for your patience and understanding.
Posted about 1 month ago. Dec 22, 2017 - 13:38 EST
Identified
Our password reset function is currently unavailable. New customers who sign up or have just signed up are not able to sign in to their accounts until the interruption is resolved. Existing customers can contact our Customer Solutions team (https://www.aweber.com/contact-us.htm) to have their password reset. Thank you for your patience as we work to resolve this situation.
Posted about 1 month ago. Dec 22, 2017 - 13:09 EST