Unscheduled Interruption
Incident Report for AWeber
Resolved
This issue has been resolved. We appreciate your patience.
Posted 6 months ago. Jun 15, 2017 - 11:27 EDT
Investigating
We are currently experiencing an unscheduled service interruption. At this time, customers may not be able to access the message editor and may experience a delay in campaign message delivery. Our team is investigating the issue and will provide updates as they become available. We appreciate your patience.
Posted 6 months ago. Jun 15, 2017 - 11:05 EDT