Scheduled Maintenance
Incident Report for AWeber
Resolved
Our scheduled maintenance is complete. We appreciate your patience.
Posted 4 months ago. Jul 05, 2017 - 16:32 EDT
Identified
In an effort to continually improve our services, we will be performing system maintenance between 2:40pm to 2:45pm ET. At this time, customers may experience delays in email sending, message analytics, and confirmed opt-in messages. We appreciate your patience.
Posted 4 months ago. Jul 05, 2017 - 14:24 EDT