Unscheduled Interruption
Incident Report for AWeber
Resolved
We have addressed the cause of the interruption, and all services should now be available. Thank you for your patience.
Posted 8 months ago. Jan 05, 2018 - 14:26 EST
Investigating
We are experiencing an unscheduled service interruption, causing a variety of services to be unavailable. We are actively investigating the cause and will provide an update as soon as possible. We apologize for the inconvenience and thank you for your patience while we work to resolve the situation. If you have any questions, please contact our Customer Solutions team: https://www.aweber.com/contact-us.htm.
Posted 8 months ago. Jan 05, 2018 - 14:16 EST