Unable to save or change status of Campaigns
Incident Report for AWeber
Resolved
Customers are now able to save and update the status of Campaigns, and Campaigns messages are sending. Thank you for your patience.
Posted 3 months ago. Jul 23, 2018 - 10:57 EDT
Update
We continue to work to resolve the Campaigns interruption. Affected customers may also experience a delay in Campaign messages being sent. We will continue to provide updates as they are available. Thank you for your patience.
Posted 3 months ago. Jul 23, 2018 - 08:15 EDT
Investigating
Some customers are reporting that they cannot save or change the status of Campaigns. We are currently working to address the interruption. All other AWeber services are working at this time, including AWeber.com, customer logins, email sending, subscriber sign ups, public API, newsletter archives, and mobile apps. We will provide updates as they become available. Thank you for your patience.
Posted 3 months ago. Jul 23, 2018 - 06:35 EDT
This incident affected: Email Sending.